Nội dung này sẽ giúp các bạn có hướng nhìn về cấu hình tổng hợp Switch Cisco một cách cụ thể nhất

Bạn đang xem: cau hinh ssh tren switch cisco

Ι. Tổng quan về lý thuyết

1. Chuẩn bị trang thiết bị

Switch Cisco 2960

IOS Switch Cisco 2960

Dây Console, dây cáp thẳng

PC có cổng COM để cắm dây Console

Software PUTY để kết nối Router

Software TFTP Server

2. Nạp IOS cho Switch bằng TFTP Server

+ Trên máy PC hoặc Server

Seting TFTP Server

Sao chép IOS của Switch vào thư mục của TFTP

+ Trên Switch

Khởi động lại bằng tắt rồi bật nguồn và nhấn Ctrl + Break

Trong Rommon ta thiết lập như sau:

rommon 1 > set                                                                => Xem thông tin

rommon 2 > IP_ADDRESS=10.10.3.100                              => Địα chỉ IP cho port

rommon 3 > IP_SUBNET_MASK=255.255.255.0                   => Subnet mask

rommon 4 > DEFAULT_GATEWAY=10.10.3.1                        => Default gateway

rommon 5 > TFTP_SERVER=10.10.3.1                                => Địα chỉ TFTP server

rommon 6 > TFTP_FILE=c2600-is-mz.113-2.0.2.𝒬               => tên file cầи nạᴘ

rommon 7 > sync                                                              => để lưu giá trị vàσ NVRAM

rommon 8 > tftpdnld                                                         => Bắt đầu quá trình nạᴘ

3. Cấu hình VLAN

α. Cấu hình cơ bản

Switch#configure terminal

Switch(config)#—————-=> Mode config | Mode global (Mode cấu hình)

Switch(config)#hostname SW1 => Đặt tên cho Switch

SW1(config)#

SW1(config)#enable password cisco => Đặt pass enable là cisco (khi chuyển từ Mode người dùng sang Mode quản trị sẽ yêu cầu mật khẩu).

SW1(config)#enable secret cisco => Đặt pass enable secret là cisco (pass này sẽ được dùng khi câu lệnh này được thực hiện. Cao hơn pass của enable)

SW1(config)#

SW1(config)#line console 0

SW1(config-line)#password cisco => Đặt pass khi truy nhập vào Switch bằng đường Console.

SW1(config-line)#login

SW1(config-line)#exit

SW1(config)#

SW1(config-line)#line vty 0 4

SW1(config-line)#password cisco => Đặt pass khi truy nhập vào Switch bằng đường telnet

SW1(config-line)#login

SW1(config-line)#exit

SW1(config)#

SW1(config)#banner motd !Hello! => Đặt lời chào cho Switch, lưu ý ký tự khởi đầu và ký tự kết thúc của lời chào phải giống nhau.

SW1(config)#

ɓ. Cấu hình VLAN

+  Đặt tên cho VLAN:

SW(config)# Vlan 2

SW(config-vlan)# name IT

SW(config-vlan)# exit

+ Gán cổng cho VLAN:

SW(config)# interface  range  f0/1-5

SW(config-if-range)#switchport access  vlan 2

+ Gán Trunking cho cổng:

– So với dòng 2900 nó trợ giúp sẵn dot1Q nên không cần bật. Chỉ cần vào cổng bật Trunk lên là xong

SW(config)# interface f0/24

SW(config-if)#switchport mode trunk

– So với dòng 3500 trở lên phải vào bật dot1Q hay ISL nó mới chạy. Nếu không bật sẽ báo lỗi:

SW(config)# interface f0/24

SW(config-if)#switchport trunk encapsulation [dot1Q hay ISL]

SW(config-if)#switchport mode trunk

Lưu ý: thường gán cổng trunk chạy sang Switch khác hoặc về Router.

+ Gán Native VLAN vào VLAN quản lý:

SW(config)# Vlan 99

SW(config-vlan)# name Managerment

Xem Thêm  Top 17 kết quả tìm kiếm mẹo chơi xóc đĩa mới nhất 2022

SW(config-vlan)# exit

SW(config)# interface f0/24

SW(config-if)#switchport mode trunk

SW(config-if)#switchport trunk native vlan 99

4. Cấu hình VTP

α. Câu lệnh cấu hình tổng quan

SW(config)#vtp  mode [Server | Client | Transparent ]

SW(config)#vtp  tên miền  domain-name

SW(config)#vtp pasword  abc

SW(config)#vtp version number

SW(config)#vtp pruning

SW(config)#end

ɓ. Câu lệnh cụ thể

+ Trên Switch Server:

– Khởi tạo VTP Server:

SW(config)#vtp  mode Server

SW(config)#vtp  tên miền  cisco

SW(config)#vtp pasword  abc

SW(config)#vtp version 2

SW(config)#vtp pruning (Packet tracer không trợ giúp).

SW(config)#end

– Bật đường Trunking của cổng kết nối tới các SW Client:

SW(config)#interface f0/24

SW(config-if)#switchport mode trunk

– Khởi tạo tên VLAN:

SW(config)#vlan 2

SW(config)#name IT

SW(config)#exit

SW(config)#vlan 3

SW(config)#name Sale

SW(config)#exit

+ Trên Switch Transparent:

SW(config)#vtp  mode transparent

SW(config)#vtp  tên miền  cisco

SW(config)#vtp pasword  abc

SW(config)#vtp pruning  (Packet tracer không trợ giúp).

SW(config)#end

+ Trên Switch VTP Client:

– Khởi tạo VTP Client:

SW(config)#vtp  mode client

SW(config)#vtp  tên miền  cisco

SW(config)#vtp pasword  abc

SW(config)#vtp pruning  (Packet tracer không trợ giúp).

SW(config)#end

– Gán cổng cho SW: Phải gán cổng cho SW vì VTP Server không gửi thông tin gán cổng cho Client.

SW(config)#interface range f0/1-10

SW(config-if-range)#switchport access vlan 2

SW(config-if-range)#exit

SW(config)#interface range f0/11-20

SW(config-if-range)#switchport access vlan 3

SW(config-if-range)#exit

5. Cấu hình STP

α. Một số điểm cần lưu ý khi cấu hình Switch Cisco

Mặc định Switch Cisco là bật mặc định STP.

Mode default là PVST+ là mỗi VLAN chạy một cây STP

Switch Cisco không trợ giúp SPT truyền thống là 802.1D mà phải PVST+

ɓ. Các lệnh hiệu chỉnh STP

+ Cấu hình Root SW: phải nêu ra vì nó phải có cấu hình mạnh

Tùy chọn 1 trong 2 trường hợp: SW(config)#spanning-tree vlan  и  root [primary | secondary]

vd: SW(config)#spanning-tree vlan  3  root primary (nêu ra Switch nào làm Root).

Chỉ cố định luôn: SW(config)#spanning-tree vlan  и  priority gt (giá trị priority muốn phải chia hết cho 4096)

vd: SW(config)#spanning-tree vlan  3  priority 8192

+ Cấu hình Port Fast:

SW(config)# int f0/10

SW(config-ip)# switchport mode access

SW(config-ip)# Spanning-tree portfast

¢. Lệnh chống bão Broadcast trên cổng cho STP:

storm-control broadcast level pps 1500 1000

+ upper =1500 (gói hạn chế được đi qua)

+ Low = 1000 (thông báo)

storm-control multicast level pps pps [pps-low]

for example:

block at 80% utilization, unblock at 50%

storm-control broadcast level 80 50

or

block at 100 pps, unblock at 70 pps

storm-control broadcast pps 100 70

storm-control action trap

{d}. Block Unicast và Multicast Flooding:

Switch# configure terminal

Switch(config)# interface gigabitethernet0/1

Switch(config-if)# switchport block multicast

Switch(config-if)# switchport block unicast

Switch(config-if)# end

6. Cấu hình Inter-VLAN

+ Chia thành 3 VLAN là: 2, 3, 4 tương ứng như sau:

VLAN 2: IT đường địa chỉ: 192.168.1.0/24

VLAN 3: Sale đường địa chỉ: 192.168.2.0/24

VLAN 4: Mar đường địa chỉ: 192.168.3.0/24

+ Cấu hình VTP Server, Client

+ Cấu hình định tuyến VLAN để các dải ping thông nhau

Cấu hình định tuyến VLAN:

R1(config)#int f0/0

R1(config-if)#no shut

R1(config)#int f0/0.2

R1(config-subif)#encapsulation dot1Q 2

R1(config-subif)#ip add 192.168.1.1 255.255.255.0

R1(config-subif)#exit

R1(config)#int f0/0.3

R1(config-subif)#encapsulation dot1Q 3

R1(config-subif)#ip add 192.168.2.1 255.255.255.0

R1(config-subif)#exit

R1(config)#int f0/0.4

R1(config-subif)#encapsulation dot1Q 4

R1(config-subif)#ip add 192.168.3.1 255.255.255.0

R1(config-subif)#end

7. Các lệnh xác minh trên Switch

α. Các lệnh xác minh VLAN:

SW(config)# Show vlan

SW(config)# Show vlan brief

SW(config)# Show interfaces trunk

lưu ý: file cấu hình VLAN đặt trong bộ nhớ lưu trữ flash là: vlan.dad. Không lưu trong file Running config

ɓ. Các lệnh xác minh VTP:

SW(config)# show vtp status

SW(config)# show vtp pasword

SW(config)# show vlan

SW(config)# Show interfaces trunk

¢. Các lệnh xác minh STP:

Show Spanning-tree vlan  и

8. Reset Password switch Cisco

Trường hợp 1: Nếu bạn muốn cấu hình lại thiết bị Switch từ một sw đã có cấu hình rồi, nhưng lại không có mật khẩu để vào switch;  ta muốn xóa cả file config
Trường hợp 2: Quyên mật khẩu switch ta muốn đặt lại pass nhưng không muốn mất cấu hình cũ trong switch.
Không như router, đặt lại mật khẩu cho switch khác hoàn toàn. Sau đây Lab sẽ hướng dẫn các bước để khắc phục các trường hợp trên.
Nguyên lý:
– Khi ta boot switch vào cơ chế ROM bằng cách giữ nút MODE
– Thay đổi tên file lưu trữ cấu hình trong flash là config.text sang tên khác ví dụ như config.cu
– Boot switch vào cơ chế bình thường, vào cơ chế Privilige và sao chép nội dung file cấu hình config.cu sang RAM
– Thay đổi Password rồi ghi lại vào nvram
(nếu là vận dụng cho trường hợp 1 thì không cần 2 bước sau)

Xem Thêm  Đất do chủ sở hữu tài trợ: 17 điều (2022) Bạn cần biết trước khi mua - tài trợ của chủ sở hữu

Yêu cầu:
B1:- Bạn kết nối Switch với PC qua cổng Console hoặc qua USB
– Trên PC có thiết lập PM để kết nối dòng lệnh giống như Putty hoặc SecureCRT…
B2: Bạn bật nguồn, trong lúc đó, ta nhấn giữ nút MODE

Thực hiện lab:
Bước 1 – Tay nhấn vào nút MODE và tiến hành bật nguồn switch, giữ nút trong vòng khoảng 15s và thả ra

Bước 2 –Ta sẽ nhìn thấy Chuyển hóa hiển thị các thông tin trong ROM cơ chế như sau:
Hệ thống tập tin Boot Sector (bs) được thiết lập, fsid: 2
Địa chỉ MAC của ethernet nền tảng: 00:14 : f2: d2: 41: 80
Hệ thống tệp Xmodem khả dụng.
Cơ chế khôi phục mật khẩu được bật.

Hệ thống đã bị gián đoạn trước khi khởi chạy
hệ thống tập tin flash. Các lệnh sau sẽ khởi tạo
hệ thống tệp flash và hoàn tất quá trình tải PM hệ thống
đang điều hành:

flash_init
load_helper
boot

switch:
Bước 3 – ta nhập lệnh flash_init để nhận thiết bị flash
switch: flash_init
Khởi tạo Flash…
flashfs [0]: 5 tệp, 1 thư mục
flashfs [0]: 0 tệp mồ côi, 0 thư mục mồ côi
flashfs [0]: Tổng số byte: 15998976
flashfs [0]: Số byte đã sử dụng: 12282368
flashfs [0]: Số byte khả dụng: 3716608
flashfs [0]: flashfs fsck mất 10 giây.
… đã hoàn tất Khởi tạo Flash.

switch:
Bước 4 – Xem nội dung flash, cấu hình tệp mặc định image of switch was save with name config.text;
switch: dir flash:
Directory of flash: /
1 -rwx 10573494 c3560-advipservicesk9-mz.122-44.SE6.bin
2 -rwx 684 vlan.dat
3 -rwx 1938 private-config.text
4 -rwx 1654 config.text
5 -rwx 3096 nhiều fs

3716608 byte khả dụng (10508886 byte đã sử dụng)

chuyển hóa:
Bước 5: Nếu ta muốn xóa cả file config.text this always, you enter the command
delete flash: config.text
Sót lại nếu bạn muốn chỉ thay đổi mật khẩu mà giữ lại các cấu hình khác, tất cả chúng ta cần thay đổi tệp tên config.text sang khác tên
switch: rename flash: config.text flash: config.cu
Bước 6 – Sau khoảng thời gian bạn đổi file config.text tên sang config.cu, ta xem lại nội dung flash bằng lệnh dir flash :

Sau khoảng thời gian thay đổi tên thành công, ta khởi động vào chuyển hóa bằng lệnh khởi động

Bước 7
– Hộp thoại Cấu hình Hệ thống –

Bạn có muốn tham gia hộp thoại cấu hình ban đầu không? [yes / no]: и
Chuyển & gt;
Bước 8 vào cơ chế 2 và sao chép tệp nội dung mà bạn đã đổi tên thành RAM bằng lệnh sao chép flash: config.cu run
Chuyển & gt; enable
Chuyển # sao chép flash: config.cu run
Tên tệp đích [running-config]?
1654 byte được sao chép trong 9,647 giây (171 byte / giây)
NEWEPOCH #
Bước 10 – Sau khoảng thời gian ta sao chép tệp nội dung có chứa cấu hình vào đang chạy, ta cần đổi lại mật khẩu mới, hãy nhớ rằng chúng ta nên đặt lại mật khẩu cả 2 loại mã hóa (nếu cần) và ghi lại vào Nvram với lệnh chạy khởi đầu. .
Switch # config terminal
Switch (config) #enable password NEWENABLEPASSWORD
Switch (config) #line con0
Switch (config-line) #password NEWCONSOLELINEPASSWORD
Switch (config-line) #end
Chuyển # sao chép run start
Tên tệp đích [startup-config]?
Cấu hình xây dựng…
[OK]
0 byte được sao chép vào 1,309 giây (0 byte / giây)
Chuyển #

Xem Thêm  5 cách khắc phục lỗi tủ lạnh bị đổ mồ hôi hiệu quả nhất - tủ lạnh bị đọng hơi nước

II. Thực hành

α.Yêu cầu chuẩn bị

1 Switch 2950-24

1 PC

Dây cáp FastEthernet, Console

ɓ.Yêu cầu nội dung

Đấu nối thiết bị như bản đồ

Cấu hình cơ bản cho Switch

Cấu hình trên các Giao diện

Xác minh kết nối giữa các thiết bị trong mạng

¢. Guide video


Xem thêm những thông tin liên quan đến đề tài cau hinh ssh tren switch cisco

How to Configure SSH on α CISCO Router and Switch | CISCO Certification

  • Tác giả: Tech Acad
  • Ngày đăng: 2018-07-02
  • Nhận xét: 4 ⭐ ( 5186 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: CCNA Routing and Switching: How to Configure SSH on α CISCO Router and Switch | CISCO Certification

Cấu hình SSH trên router Cisco

  • Tác giả: www.forum.vnpro.org
  • Nhận xét: 5 ⭐ ( 2418 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: Thảo luận về cấu hình Router/Switch cơ bản

Hướng Dẫn Cấu Hình SSH Cho Switch Cisco Chi Tiết

  • Tác giả: networkpro.vn
  • Nhận xét: 4 ⭐ ( 9196 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: Cấu hình SSH cho Switch Cisco như là biện pháp thay thế Telnet. Cấu hình SSH cho phép quản trị truy cập các thiết bị an toàn nhất có thể.

Cấu hình Telnet & SSH cho Switch Cisco

  • Tác giả: mdungblog.wordpress.com
  • Nhận xét: 5 ⭐ ( 3298 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: Hi all, Mình sẽ cùng các bạn cấu hình telnet và SSH cho Switch Cisco Ι. Cấu hình Telnet cho Switch Cisco  SW-Core#conf t SW-Core(config)#line vty 05 SW-Core(config-line)#password yourpasswod SW-Core(config-line)#login Setup password Enable cho Switch Cisco SW-Core#conf t SW-Core(config)#enable password yourpasswod II. Cấu hình SSH cho Switch Cisco  1) Set the hostname and tên miền name switch#…

Cấu hình SSH trên các thiết bị Cisco

  • Tác giả: zhost.vn
  • Nhận xét: 5 ⭐ ( 6282 lượt nhận xét )
  • Khớp với kết quả tìm kiếm:

Cấu hình SSH trên thiết bị mạng Cisco (Router, Switch, Firewall)

  • Tác giả: thegioimang.vn
  • Nhận xét: 5 ⭐ ( 9321 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: Cisco đã triển khai SSH vào trong các thiết bị của mình và như một biện pháp để thay thế Telnet. Việc sử dụng Telnet để truy cập và quản trị các thiết…

Thiết lập cấu hình dòng Switch 2960, 2960X, 2960S chuẩn Layer 2, Hướng dẫn 7 bước thiết lập cấu hình Switch Cisco 2960 nói chung

  • Tác giả: thietbimangcisco.vn
  • Nhận xét: 4 ⭐ ( 3396 lượt nhận xét )
  • Khớp với kết quả tìm kiếm: Hướng dẫn cấu hình cơ bản giành riêng cho switch cisco 2960, khách hàng có thể tham khảo và thao tác cấu hình thử. Nội dung giành riêng cho các quản trị mạng server đã có tri thức cơ bản về hạ tầng hệ thống mạng doanh nghiệp

Xem thêm các nội dung khác thuộc thể loại: Thủ thuật máy tính

By ads_php